More robust handling for installed headers
[alexxy/gromacs.git] / src / gromacs / utility / CMakeLists.txt
index b08dcfc5ab30e755ad4f1dfb754ad29edec2eb77..a478811e40c4c10e0cb3db4c00aa9da2e9090569 100644 (file)
@@ -35,7 +35,7 @@
 file(GLOB UTILITY_SOURCES *.c *.cpp)
 set(LIBGROMACS_SOURCES ${LIBGROMACS_SOURCES} ${UTILITY_SOURCES} PARENT_SCOPE)
 
-set(UTILITY_PUBLIC_HEADERS
+gmx_install_headers(
     arrayref.h
     basedefinitions.h
     cstringutil.h
@@ -54,7 +54,6 @@ set(UTILITY_PUBLIC_HEADERS
     smalloc.h
     stringutil.h
     )
-gmx_install_headers(utility ${UTILITY_PUBLIC_HEADERS})
 
 if (BUILD_TESTING)
     add_subdirectory(tests)