More robust handling for installed headers
[alexxy/gromacs.git] / src / gromacs / topology / CMakeLists.txt
index ffc2379e839c32e2177ce1bbd747868e8e8457cf..fc8b5463b9f1045d28f191d21c8315c14dd4ee9c 100644 (file)
@@ -35,7 +35,7 @@
 file(GLOB TOPOLOGY_SOURCES *.cpp *.c)
 set(LIBGROMACS_SOURCES ${LIBGROMACS_SOURCES} ${TOPOLOGY_SOURCES} PARENT_SCOPE)
 
-set(TOPOLOGY_PUBLIC_HEADERS
+gmx_install_headers(
     atomprop.h
     atoms.h
     block.h
@@ -43,9 +43,8 @@ set(TOPOLOGY_PUBLIC_HEADERS
     index.h
     mtop_util.h
     symtab.h
-    topology.h)
-
-gmx_install_headers(topology ${TOPOLOGY_PUBLIC_HEADERS})
+    topology.h
+    )
 
 if (BUILD_TESTING)
 #    add_subdirectory(tests)