More robust handling for installed headers
[alexxy/gromacs.git] / src / gromacs / selection / CMakeLists.txt
index 4788a17578a1aa2e0b96d86260c94bd50ba163a5..02e565c82ac7d1b67c79d8e9e5b6f53438c32e2f 100644 (file)
@@ -35,7 +35,7 @@
 file(GLOB SELECTION_SOURCES *.cpp)
 set(LIBGROMACS_SOURCES ${LIBGROMACS_SOURCES} ${SELECTION_SOURCES} PARENT_SCOPE)
 
-set(SELECTION_PUBLIC_HEADERS
+gmx_install_headers(
     nbsearch.h
     indexutil.h
     position.h
@@ -43,8 +43,8 @@ set(SELECTION_PUBLIC_HEADERS
     selectioncollection.h
     selectionenums.h
     selectionoption.h
-    selectionoptionmanager.h)
-gmx_install_headers(selection ${SELECTION_PUBLIC_HEADERS})
+    selectionoptionmanager.h
+    )
 
 if (BUILD_TESTING)
     add_subdirectory(tests)