More robust handling for installed headers
[alexxy/gromacs.git] / src / gromacs / options / CMakeLists.txt
index 446c55228a5a3401cae1ecf62c72d45c6cbd9014..a04d94e1a184ab50c61fe45137f0f43c1ec62f4c 100644 (file)
@@ -35,7 +35,7 @@
 file(GLOB OPTIONS_SOURCES *.cpp)
 set(LIBGROMACS_SOURCES ${LIBGROMACS_SOURCES} ${OPTIONS_SOURCES} PARENT_SCOPE)
 
-set(OPTIONS_PUBLIC_HEADERS
+gmx_install_headers(
     abstractoption.h
     basicoptions.h
     filenameoption.h
@@ -43,8 +43,8 @@ set(OPTIONS_PUBLIC_HEADERS
     optionfiletype.h
     optionflags.h
     options.h
-    timeunitmanager.h)
-gmx_install_headers(options ${OPTIONS_PUBLIC_HEADERS})
+    timeunitmanager.h
+    )
 
 if (BUILD_TESTING)
     add_subdirectory(tests)