Add basic tests for reading/writing structure files
[alexxy/gromacs.git] / src / gromacs / fileio / tests / CMakeLists.txt
index b0f62731b68418d10f8cf47e9d5f7b0bb073173a..8f83ed1cca72940202b559308d4b1eb2324ec14b 100644 (file)
@@ -1,7 +1,7 @@
 #
 # This file is part of the GROMACS molecular simulation package.
 #
-# Copyright (c) 2013,2014, by the GROMACS development team, led by
+# Copyright (c) 2013,2014,2015, by the GROMACS development team, led by
 # Mark Abraham, David van der Spoel, Berk Hess, and Erik Lindahl,
 # and including many others, as listed in the AUTHORS file in the
 # top-level source directory and at http://www.gromacs.org.
 # To help us fund GROMACS development, we humbly ask that you cite
 # the research papers on the package. Check out http://www.gromacs.org.
 
-if(GMX_USE_TNG)
-    gmx_add_unit_test(FileIOTests fileio-test
-        tngio.cpp)
+set(test_sources
+    confio.cpp
+    )
+if (GMX_USE_TNG)
+    list(APPEND test_sources tngio.cpp)
 endif()
+gmx_add_unit_test(FileIOTests fileio-test ${test_sources})