Implement PME solve in SYCL
[alexxy/gromacs.git] / src / gromacs / ewald / CMakeLists.txt
index 78d2a4ed02b2b5eebdf1fd3533c4a12e24e038fb..fd24566ee0c883f576b1f9ed6ab3e7efb32e2238 100644 (file)
@@ -92,8 +92,9 @@ elseif (GMX_GPU_SYCL)
         pme_gpu.cpp
         pme_gpu_internal.cpp
         pme_gpu_program_impl_sycl.cpp
-        pme_spread_sycl.cpp
         pme_gpu_timings.cpp
+        pme_solve_sycl.cpp
+        pme_spread_sycl.cpp
         )
     _gmx_add_files_to_property(SYCL_SOURCES
         pme_gather_sycl.cpp
@@ -102,6 +103,7 @@ elseif (GMX_GPU_SYCL)
         pme_gpu_program_impl_sycl.cpp
         pme_gpu_3dfft_sycl.cpp
         pme_gpu_timings.cpp
+        pme_solve_sycl.cpp
         pme_spread_sycl.cpp
       )
 else()